nix-gh/tests/timeout.nix
Will Dietz a0c56197fc tests/timeout: create output so tests don't trivially pass
Timeout tests rely on failed build to determine success,
so make sure these derivations (silent in particular)
don't fail regardless of timeout behavior.
2017-04-08 12:59:42 -05:00

32 lines
506 B
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

with import ./config.nix;
{
infiniteLoop = mkDerivation {
name = "timeout";
buildCommand = ''
touch $out
echo "timeout builder entering an infinite loop"
while true ; do echo -n .; done
'';
};
silent = mkDerivation {
name = "silent";
buildCommand = ''
touch $out
sleep 60
'';
};
closeLog = mkDerivation {
name = "silent";
buildCommand = ''
touch $out
exec > /dev/null 2>&1
sleep 1000000000
'';
};
}