nix-gh/tests/lang/eval-okay-string.nix

13 lines
268 B
Nix

"foo" + "bar"
+ toString (/a/b + /c/d)
+ toString (/foo/bar + "/../xyzzy/." + "/foo.txt")
+ ("/../foo" + toString /x/y)
+ "escape: \"quote\" \n \\"
+ "end
of
line"
+ "foo${if true then "b${"a" + "r"}" else "xyzzy"}blaat"
+ "foo$bar"
+ "$\"$\""
+ "$"