nix-gh/tests/lang/eval-okay-with.nix

20 lines
171 B
Nix

let {
a = "xyzzy";
as = {
a = "foo";
b = "bar";
};
bs = {
a = "bar";
};
x = with as; a + b;
y = with as; with bs; a + b;
body = x + y;
}